Start a new topic

What version?

The web site says that the app runs on ios 7 or newer, however on one of my phones, it will only download the old version because it says it needs ios 9.  

Login or Signup to post a comment